Was brauchen Sie?

DruckversionPDF version

Sie benötigen für Ihre Joomla Webseite

  • einen Internet-Server,
  • eine Sql-Datenbank und
  • die Bibliotheken der Programmier/Skriptsprache PHP.

Entweder Sie installieren Joomla

  • auf dem Webspace eines Hosters - das Hosting-Paket muss MySql und PHP beinhalten, oder
  • bis Ihre Webseite erstellt ist - lokal auf Ihrem PC - mit einem lokalen Server z.B. xampp von apachefriends.org

Die MySql Version und PHP Version müssen dabei den Spezifikationen der Joomla Version entsprechen. Üblicherweise ist  Joomla mit den jeweils neuesten MySql und PHP Versionen kompatibel. Hoster bieten in ihrem Kundenmenü meist mehrere PHP bzw. MySql-Versionen zur Auswahl an.

Joomla läuft somit unabhängig von Ihrem PC-Betriebssystem. Sie können über den Webserver Ihres Hoster von jedem Computer aus über das Internet auf die Joomla Verwaltung zugreifen.
Einen lokalen Webserver gibt es für jedes PC-Betriebssystem, z.B. xampp von apachefriends für Windows, Mac und Linux. 
Lokal können Sie die Webseite ohne Internetverbindung und Zugriff erstellen, haben Sie die Seite einmal ins Netz/zu Ihrem Hoster hochgeladen, arbeiten Sie nur noch online.

Sie finden die aktuellen technischen Voraussetzung auf der offiziellen Joomla-Seite.

also für Joomla Version 3.x

  empfohlen Minimum
PHP (Magic Quotes GPC off)[1] 5.4 + 5.3.10 + http://www.php.net
Datenbanken
MySQL (InnoDB support required) 5.1 + 5.1 + http://www.mysql.com
SQL Server 10.50.1600.1+ 10.50.1600.1+ http://www.microsoft.com/sql
PostgreSQL 8.3.18 + 8.3.18 + http://www.postgresql.org/
Unterstützte Internetserver:
Apache[2]
(mit mod_mysql, mod_xml, and mod_zlib)
2.x + 2.x + http://www.apache.org
Nginx 1.1 1.0 http://wiki.nginx.org/
Microsoft IIS[5] 7 7 http://www.iis.net

1] PHP 5.3.1 ist erforderlich für Joomla  3.0 bis einschließlich 3.2. Ab 3.3 PHP 5.3.10 ist Minimum

[2] IApache mod_rewrite Erweiterung ist nicht erforderlich für benutzerfreundliche URLs.

[3]  PHP 4.3.9, 4.4.2 oder 5.0.4 bereiten Probleme. OpenID library ist nicht kompatibel mit PHP 5.3.

rhein-main-experten.de wird überprüft von der Initiative-S